Where do I find 1.8.8 versions of plugins? Essentials etc?

With the release of Spigot 1.8, a considerable number of plugins need updating. We've put together a list of popular plugins below that require updates for 1.8:

Worldguard: http://dev.bukkit.org/bukkit-plugins/worldguard/files/
Worldedit: http://dev.bukkit.org/bukkit-plugins/worldedit/files/
PermissionsEx: http://dev.bukkit.org/bukkit-plugins/permissionsex/files/
Citizens: http://ci.citizensnpcs.co/job/Citizens2/
Craftbook: http://ci.md-5.net/job/CraftBook/lastSuccessfulBuild/artifact/target/craftbook-3.9-SNAPSHOT.jar

The Essentials download for 1.8 is not very obvious, it can be gotten from here: 

Core: https://ci.drtshock.net/job/EssentialsX/lastSuccessfulBuild/artifact/Essentials/target/EssentialsX-2.0.1.jar
Antibuild: https://ci.drtshock.net/job/EssentialsX/lastSuccessfulBuild/artifact/EssentialsAntiBuild/target/EssentialsXAntiBuild-2.0.1.jar
Chat: https://ci.drtshock.net/job/EssentialsX/lastSuccessfulBuild/artifact/EssentialsChat/target/EssentialsXChat-2.0.1.jar 
Protect: https://ci.drtshock.net/job/EssentialsX/lastSuccessfulBuild/artifact/EssentialsProtect/target/EssentialsXProtect-2.0.1.jar 
Spawn: https://ci.drtshock.net/job/EssentialsX/lastSuccessfulBuild/artifact/EssentialsSpawn/target/EssentialsXSpawn-2.0.1.jar 

Upload the above jars via FTP (Files -> FTP File Access -> Login -> Plugins -> Upload) into your plugins folder ensuring you delete the old jars of the above plugins if present. Once this is completed, restart your server and they should be working.

Was this answer helpful?

 Print this Article

Also Read

How to Update Your Minecraft Server Version (Non-Modded)

Step 1: Check to see if the version in brackets beside your jar selection name on a Multicraft is...

How to add a user to your Multicraft account

To add a user to your server, ask them to register here:...

How to setup a whitelist

A whitelist allows you to restrict the players that are able to join your Minecraft...

How to add a server icon to your server

1. Make a picture that is 64 x 64 (pixels).2. Save it as "server-icon.png" it MUST be a .png...

How to Setup BungeeCord

Requirements for BungeeCord:- A single server for BungeeCord to run on, a 256mb premium or 1gb...